Online Help > Installation > Upgrading Devolutions Password Server

Upgrading to 6.0

Description

 

BadgeNotice48x48

Please contact the support team for an appointment.  We will perform the upgrade with you in a remote session.

 

Dependencies

 

BadgeInfo48x48

The Devolutions Password Server Console is needed to perform the upgrade. It is now offered as a stand alone application and is available on the Download page.

 

BadgeInfo48x48

Devolutions Password Server needs Microsoft .Net Framework 4.7.2 to function. Please adapt your environment depending on which version you are running.

 

BadgeInfo48x48

The recommended Remote Desktop Manager version to use with Devolutions Password Server is version 14.0.0.0 or higher. It is available on the Download page.

 

BadgeCaution48x48

If you have set the Shared Passphrase v1 Security Provider on your current Devolutions Password Server instance, specific operations will need to be done before the upgrade. Please contact us for further details.

 

BadgeCaution48x48

If you have set the Certificate Security Provider, because it is required for the web interface and because some encryption/decryption operations are now executed by the backend, the Certificate must be accessible by the Devolutions Password Server instance on the machine where it is hosted.